Brightwork update number 2

Almost done …

Brightwork update

It’s been cold and wet in Sidney. The brightwork is progressing just a bit slower than planned. We should have had the boat back by now, but the cold and wet weather has delayed the return by a couple of weeks. Don at Avalon Brightwork was kind enough to send me some photos of the progress.

As these photos show, it was clearly time for some serious brightwork TLC.

Continue reading

Trying to fix our deck freezer

Archimedes came with a giant deck freezer on the flybridge when we purchased her. Since that time, the deck freezer has never worked. In fact, it could not have ever worked. Even for the folks that put it on the boat originally. The basic problem can be defined as this — it doesn’t get cold. With the thermostat set to its coldest setting, the freezer will get down to the mid 30’s. That’s makes it a serviceable refrigerator, but this is supposed to be a freezer. It also uses 5-6 amps all the time while the compressor is running.

From time to time I’ve tried to get it to work right, but without success. I’ve rewired the power (more on that later). We had the guts replaced (in hindsight, we probably didn’t need to). And it still doesn’t get cold. The compressor runs all the time and there is lots of frost buildup inside.

We took it to a reputable repair facility. They told us they added refrigerant and it worked right for them. But it still won’t get cold for us.

As it turns out, it took a fair bit of internet sleuthing to locate a likely solution, but I did find it. I think. Maybe. Of course, I could be completely wrong. And I am making a big assumption. I am assuming it can work properly as a freezer.

mv-archimedes-deck-freezer-1 Continue reading